# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?m)\s*^[0-9]{4}-[0-9]{2}-[0-9]{2}.*//g;t' <<< "Line 1
1234-23-22 Some text
More text"