using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?m)\s*^[0-9]{4}-[0-9]{2}-[0-9]{2}.*";
string substitution = @"";
string input = @"Line 1
1234-23-22 Some text
More text";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}