const regex = new RegExp('(?m)\\s*^[0-9]{4}-[0-9]{2}-[0-9]{2}.*', 'g')
const str = `Line 1
1234-23-22 Some text
More text`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);