re = /(?m)\s*^[0-9]{4}-[0-9]{2}-[0-9]{2}.*/
str = 'Line 1
1234-23-22 Some text
More text'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result