#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\s*^[0-9]{4}-[0-9]{2}-[0-9]{2}.*"
Local $sString = "Line 1" & @CRLF & _
"" & @CRLF & _
"1234-23-22 Some text" & @CRLF & _
"More text"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)