package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\s*^[0-9]{4}-[0-9]{2}-[0-9]{2}.*`)
var str = `Line 1
1234-23-22 Some text
More text`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}