$re = '`(?m)\s*^[0-9]{4}-[0-9]{2}-[0-9]{2}.*`';
$str = 'Line 1
1234-23-22 Some text
More text';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;