// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\s*^[0-9]{4}-[0-9]{2}-[0-9]{2}.*").unwrap();
let string = "Line 1
1234-23-22 Some text
More text";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}