use strict;
my $str = 'Line 1
1234-23-22 Some text
More text';
my $regex = qr`(?m)\s*^[0-9]{4}-[0-9]{2}-[0-9]{2}.*`p;
my $subst = '';
my $result = $str =~ s`$regex`$subst`rg;
print "The result of the substitution is' $result\n";