import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\S\\(<td>)(.+?)(<\\/td>)|(<td><a href\\s*=) |(\\\"[^\\\"]*\\\")";
final String string = "\" <td>PFltLd_stAshRstEEP</td><td><a href=\"PFltLd_AshLoadFuelCnt.htm?1_PFltLd_stAshRstEEP\">AshLoadFuelCnt_1</a><br>\n"
+ "<a href=\"PFltLd_AshLoadTimeCorr.htm?1_PFltLd_stAshRstEEP\">AshLoadTimeCorr_1</a><br>\n"
+ "</td>";
final String subst = "\\1\\2";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}