import Foundation
let pattern = #"\S\(<td>)(.+?)(<\/td>)|(<td><a href\s*=) |(\"[^\"]*\")"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
" <td>PFltLd_stAshRstEEP</td><td><a href="PFltLd_AshLoadFuelCnt.htm?1_PFltLd_stAshRstEEP">AshLoadFuelCnt_1</a><br>
<a href="PFltLd_AshLoadTimeCorr.htm?1_PFltLd_stAshRstEEP">AshLoadTimeCorr_1</a><br>
</td>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1\2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)