const regex = /\S\(<td>)(.+?)(<\/td>)|(<td><a href\s*=) |(\"[^\"]*\")/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\S\\(<td>)(.+?)(<\\\/td>)|(<td><a href\\s*=) |(\\"[^\\"]*\\")', 'g')
const str = `" <td>PFltLd_stAshRstEEP</td><td><a href="PFltLd_AshLoadFuelCnt.htm?1_PFltLd_stAshRstEEP">AshLoadFuelCnt_1</a><br>
<a href="PFltLd_AshLoadTimeCorr.htm?1_PFltLd_stAshRstEEP">AshLoadTimeCorr_1</a><br>
</td>`;
const subst = `\1\2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);