# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([\s\S]*?)(\S*(\.)\S*)/$2\n/gm;t' <<< "SELECT *
FROM db.table1
UNION ALL
SELECT *
FROM db.table2"