const regex = /([\s\S]*?)(\S*(\.)\S*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([\\s\\S]*?)(\\S*(\\.)\\S*)', 'gm')
const str = `SELECT *
FROM db.table1
UNION ALL
SELECT *
FROM db.table2`;
const subst = `$2\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);