use strict;
my $str = 'SELECT *
FROM db.table1
UNION ALL
SELECT *
FROM db.table2';
my $regex = qr/([\s\S]*?)(\S*(\.)\S*)/mp;
my $subst = '$2\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";