// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)([\s\S]*?)(\S*(\.)\S*)").unwrap();
let string = "SELECT *
FROM db.table1
UNION ALL
SELECT *
FROM db.table2";
let substitution = "$2\\n";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}