using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([\s\S]*?)(\S*(\.)\S*)";
string substitution = @"$2\n";
string input = @"SELECT *
FROM db.table1
UNION ALL
SELECT *
FROM db.table2";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}