re = /([\s\S]*?)(\S*(\.)\S*)/m
str = 'SELECT *
FROM db.table1
UNION ALL
SELECT *
FROM db.table2'
subst = '$2\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result