import Foundation
let pattern = #"([\s\S]*?)(\S*(\.)\S*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
SELECT *
FROM db.table1
UNION ALL
SELECT *
FROM db.table2
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$2\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)