import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([\\s\\S]*?)(\\S*(\\.)\\S*)";
final String string = "SELECT *\n"
+ "FROM db.table1\n"
+ "UNION ALL\n"
+ "SELECT *\n"
+ "FROM db.table2";
final String subst = "$2\\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}