package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([\s\S]*?)(\S*(\.)\S*)`)
var str = `SELECT *
FROM db.table1
UNION ALL
SELECT *
FROM db.table2`
var substitution = "$2\n"
fmt.Println(re.ReplaceAllString(str, substitution))
}