# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<div class="head">[\s\r\n]*([\w ]+)[\s\r\n]*<\\/div>/<h1>$1<\/h1>/;t' <<< "<div class=\"head\">
Keep this text</div>"