const regex = /<div class="head">[\s\r\n]*([\w ]+)[\s\r\n]*<\/div>/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<div class="head">[\\s\\r\\n]*([\\w ]+)[\\s\\r\\n]*<\\\/div>', '')
const str = `<div class="head">
Keep this text</div>`;
const subst = `<h1>$1</h1>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);