// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"<div class="head">[\s\r\n]*([\w ]+)[\s\r\n]*<\/div>"#).unwrap();
let string = "<div class=\"head\">
Keep this text</div>";
let substitution = "<h1>$1</h1>";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}