re = /<div class="head">[\s\r\n]*([\w ]+)[\s\r\n]*<\/div>/
str = '<div class="head">
Keep this text</div>'
subst = '<h1>$1</h1>'
result = str.sub(re, subst)
# Print the result of the substitution
puts result