package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<div class="head">[\s\r\n]*([\w ]+)[\s\r\n]*<\/div>`)
var str = []byte(`<div class="head">
Keep this text</div>`)
var substitution = []byte("<h1>$1</h1>")
var count = 1 // negative counter is equivalent to global case (replace all)
str = re.ReplaceAllStringFunc(str, func(s string) string {
if count == 0 {
return s
}
count -= 1
return re.ReplaceAllString(s, substitution)
})
fmt.Println(string(str))
}