use strict;
my $str = '<div class="head">
Keep this text</div>';
my $regex = qr/<div class="head">[\s\r\n]*([\w ]+)[\s\r\n]*<\/div>/p;
my $subst = '<h1>$1</h1>';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";