import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<div class=\"head\">[\\s\\r\\n]*([\\w ]+)[\\s\\r\\n]*<\\/div>";
final String string = "<div class=\"head\"> \n\n\n"
+ " Keep this text</div>";
final String subst = "<h1>$1</h1>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}