import Foundation
let pattern = #"<div class="head">[\s\r\n]*([\w ]+)[\s\r\n]*<\/div>"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<div class="head">
Keep this text</div>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<h1>$1</h1>"#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}