using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(<[^<>]*>;\srel=\""(next|prev|last|first)\""(,\s)?)*$";
string input = @"<https://api.github.com/user/25254/followers?page=21>; rel=""next"", <https://api.github.com/user/25254/followers?page=332>; rel=""last"", <https://api.github.com/user/25254/followers?page=1>; rel=""first"", <https://api.github.com/user/25254/followers?page=19>; rel=""prev""";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}