re = /^(<[^<>]*>;\srel=\"(next|prev|last|first)\"(,\s)?)*$/
str = '<https://api.github.com/user/25254/followers?page=21>; rel="next", <https://api.github.com/user/25254/followers?page=332>; rel="last", <https://api.github.com/user/25254/followers?page=1>; rel="first", <https://api.github.com/user/25254/followers?page=19>; rel="prev"'
# Print the match result
str.match(re) do |match|
puts match.to_s
end