import re
regex = re.compile(r"^(<[^<>]*>;\srel=\"(next|prev|last|first)\"(,\s)?)*$")
test_str = "<https://api.github.com/user/25254/followers?page=21>; rel=\"next\", <https://api.github.com/user/25254/followers?page=332>; rel=\"last\", <https://api.github.com/user/25254/followers?page=1>; rel=\"first\", <https://api.github.com/user/25254/followers?page=19>; rel=\"prev\""
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")