// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"^(<[^<>]*>;\srel=\"(next|prev|last|first)\"(,\s)?)*$"#).unwrap();
let string = "<https://api.github.com/user/25254/followers?page=21>; rel=\"next\", <https://api.github.com/user/25254/followers?page=332>; rel=\"last\", <https://api.github.com/user/25254/followers?page=1>; rel=\"first\", <https://api.github.com/user/25254/followers?page=19>; rel=\"prev\"";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}