package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(<[^<>]*>;\srel=\"(next|prev|last|first)\"(,\s)?)*$`)
var str = `<https://api.github.com/user/25254/followers?page=21>; rel="next", <https://api.github.com/user/25254/followers?page=332>; rel="last", <https://api.github.com/user/25254/followers?page=1>; rel="first", <https://api.github.com/user/25254/followers?page=19>; rel="prev"`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}