import Foundation
let pattern = #"^(<[^<>]*>;\srel=\"(next|prev|last|first)\"(,\s)?)*$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"<https://api.github.com/user/25254/followers?page=21>; rel="next", <https://api.github.com/user/25254/followers?page=332>; rel="last", <https://api.github.com/user/25254/followers?page=1>; rel="first", <https://api.github.com/user/25254/followers?page=19>; rel="prev""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}