import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(<[^<>]*>;\\srel=\\\"(next|prev|last|first)\\\"(,\\s)?)*$";
final String string = "<https://api.github.com/user/25254/followers?page=21>; rel=\"next\", <https://api.github.com/user/25254/followers?page=332>; rel=\"last\", <https://api.github.com/user/25254/followers?page=1>; rel=\"first\", <https://api.github.com/user/25254/followers?page=19>; rel=\"prev\"";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}