#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(?:\"(.+?)\"|([^\s]+)).*"
Local $sString = "c:\tools\foo.exe" & @CRLF & _
"c:\tools\foo.exe -bar" & @CRLF & _
""C:\Program Files\bar.exe"" & @CRLF & _
""C:\Program Files\bar.exe" -baz" & @CRLF & _
""
Local $sSubst = "$1$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)