import re
regex = re.compile(r"^(?:\"(.+?)\"|([^\s]+)).*", flags=re.MULTILINE)
test_str = ("c:\\tools\\foo.exe\n"
"c:\\tools\\foo.exe -bar\n"
"\"C:\\Program Files\\bar.exe\"\n"
"\"C:\\Program Files\\bar.exe\" -baz\n")
subst = "$1$2"
result = regex.sub(subst, test_str)
if result:
print(result)