use strict;
my $str = 'c:\\tools\\foo.exe
c:\\tools\\foo.exe -bar
"C:\\Program Files\\bar.exe"
"C:\\Program Files\\bar.exe" -baz
';
my $regex = qr/^(?:\"(.+?)\"|([^\s]+)).*/mp;
my $subst = '$1$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";