import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:\\\"(.+?)\\\"|([^\\s]+)).*";
final String string = "c:\\tools\\foo.exe\n"
+ "c:\\tools\\foo.exe -bar\n"
+ "\"C:\\Program Files\\bar.exe\"\n"
+ "\"C:\\Program Files\\bar.exe\" -baz\n";
final String subst = "$1$2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}