// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)^(?:\"(.+?)\"|([^\s]+)).*"#).unwrap();
let string = "c:\\tools\\foo.exe
c:\\tools\\foo.exe -bar
\"C:\\Program Files\\bar.exe\"
\"C:\\Program Files\\bar.exe\" -baz
";
let substitution = "$1$2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}