import Foundation
let pattern = #"^(?:\"(.+?)\"|([^\s]+)).*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
c:\tools\foo.exe
c:\tools\foo.exe -bar
"C:\Program Files\bar.exe"
"C:\Program Files\bar.exe" -baz
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)