$re = '/^(?:\"(.+?)\"|([^\s]+)).*/m';
$str = 'c:\\tools\\foo.exe
c:\\tools\\foo.exe -bar
"C:\\Program Files\\bar.exe"
"C:\\Program Files\\bar.exe" -baz
';
$subst = "$1$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;