package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:\"(.+?)\"|([^\s]+)).*`)
var str = `c:\tools\foo.exe
c:\tools\foo.exe -bar
"C:\Program Files\bar.exe"
"C:\Program Files\bar.exe" -baz
`
var substitution = "$1$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}