re = /^(?:\"(.+?)\"|([^\s]+)).*/m
str = 'c:\\tools\\foo.exe
c:\\tools\\foo.exe -bar
"C:\\Program Files\\bar.exe"
"C:\\Program Files\\bar.exe" -baz
'
subst = '$1$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result