# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^\<\!\-\-\#([a-z]+?)\s([a-z]*\=\".*\")+? \-\-\>$//gm;t' <<< "<!--#include file=\"test\" set=\"one\" two=\"asdf\" -->
"