use strict;
my $str = '<!--#include file="test" set="one" two="asdf" -->
';
my $regex = qr/^\<\!\-\-\#([a-z]+?)\s([a-z]*\=\".*\")+? \-\-\>$/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";