// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)^\<\!\-\-\#([a-z]+?)\s([a-z]*\=\".*\")+? \-\-\>$"#).unwrap();
let string = "<!--#include file=\"test\" set=\"one\" two=\"asdf\" -->
";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}