using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\<\!\-\-\#([a-z]+?)\s([a-z]*\=\"".*\"")+? \-\-\>$";
string substitution = @"";
string input = @"<!--#include file=""test"" set=""one"" two=""asdf"" -->
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}