import re
regex = re.compile(r"^\<\!\-\-\#([a-z]+?)\s([a-z]*\=\".*\")+? \-\-\>$", flags=re.MULTILINE)
test_str = ("<!--#include file=\"test\" set=\"one\" two=\"asdf\" -->\n")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)